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Introduction 

How It All Began 

In early 2003 Peter PHP1PH and myself Simon HB9DRV talked about 

developing a simple program to control the soon to be released ICOM IC-703. 

We had previously developed the FT-817 Commander, which proved to be very 

popular, the main lesson being learnt that future programs must not be tied to a 

single radio or a single manufacturer; rather they must be designed to support all 

current and future radios. 

Maybe it was the beer, maybe the desire to give something back to the radio 

amateur community, however on June 6
th
, 2003 the first line of code was written, 

Ham Radio Deluxe (HRD) was born. 

The inspiration for the design came from a variety of sources: Internet Explorer 

(especially the Favourites), my old Eddystone EA12 and a desire to prove that 

Peter and myself could develop something better than the current ónot quite so 

free and fantasticô products being peddled to radio amateurs. 

On December 23
rd
, 2005 the number of registered users stood at 20,006 ï quite 

an achievement in such a short time. 

---   ---   --- 

Very sadly Peter passed away on June 8
th
, 2005. His contribution to Ham Radio 

Deluxe will never be forgotten. 

 



This Guide 

Kevin Crockett, VK3CKC, wrote the original user guide. Now that HRD is a 

more mature product the time has come to write the document you are currently 

reading. 

Thank-you for reading this guide - and before you ask itôs written in British 

English, with plenty of my favourite colours despite Wordôs attempts to change 

the spelling J. 

If you are only going to read one more section then now go to Radio Display on 

page 23. 

Please report errors and omissions to simon@hb9drv.ch or in the HRD forums 

http://forums.ham-radio.ch/ . 

The Name 

The influence for the name comes from Eight Ball Deluxe, which was one of the 

finest Macintosh games of the 1990ôs. 

   

Sponsors 

To help keep HRD free for all Amateurs and SWLôs several companies have 

helped by sponsoring the HRD development. If I have missed your company 

please let me know. 

And a very big thank-you to everybody when has lent radios to Peter and myself 

so that we have been able to provide the current level of support. 

 

mailto:simon@hb9drv.ch
http://forums.ham-radio.ch/
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Requirements 

Computer 

You can run HRD on any Windows 98 or Windows NT/2K/XP computer. Please 

note: version 3.4 is the last release that will óintentionallyô run on Windows 98. 

There will never be a LINUX or Macintosh native version, HRD is known to run 

under Wine for LINUX and PC emulators for the Macintosh. 

 

I may be crazy undertaking a project like this in my spare time
1
; I am not ódeep 

stir-fry serve in a bun with extra chiliesô crazy
2
! 

 

The code is not open source; it cannot be ported to Linux and will never be 

released as some of the code is protected under copyright and if released will 

land the author with a nice big legal ófeeô. 

Supported Radios 

You donôt need a radio ï HRD comes with built-in Dem-o-matic radio support 

(FTDX-9000, K2, Orion, TS-480, TS-570 and TS-2000). 

HRD currently supports these órealô radios: 

¶ Elecraft: K2 

¶ FlexRadio: SDR-1000 

¶ ICOM: IC-7000, IC-703, IC-706, IC-706MkII, IC-706MkIIG, IC-

707, IC-718, IC-725, IC-726, IC-728, IC-729, IC-735, IC-736, IC-

737, IC-738, IC-7400, IC-746, IC-746Pro, IC-751A, IC-751A 

(Piexx), IC-756, IC-756Pro, IC-756ProII, IC-756ProIII, IC-761, 

IC-765, IC-775DSP, IC-7800, IC-781, IC-821H, IC-910H, IC-R10, 

IC-R20, IC-R7000, IC-R75, IC-R8500, IC-R9000, PCR-1000 

¶ Kenwood: R-5000, TS-140S, TS-2000, TS-440S, TS-450S, TS-

480, TS-50S, TS-570, TS-60S, TS-680S, TS-690S, TS-790, TS-

850, TS-870, TS-940S, TS-950, TS-B2000 

¶ Ten-Tec: Argonaut, Jupiter, Orion, RX-350 

¶ Yaesu: FT-100, FT-1000D, FT-1000MP MkV, FT-600, FT-817, 

FT-840, FT-847, FT-857, FT-890, FT-897, FT-900, FT-920, FT-

990, FTDX-9000. 

                                                           
1
 It was the voices in my head that made me do it 

2
 Medical opinion may differ here 



Interfacing 

You will need a cable to connect your radio to the computerôs serial (COM) port. 

If you donôt have a serial port all is not lost ï USB ė serial converters are 

widely available. Please note: not all USB ė serial converters work well enough 

for HRD. If in doubt ask for a recommendation in the HRD support forums. 

For more interfacing information refer to: 

¶ The HRD Interface guide, and 

¶ CATbox, a Modular Computer Interface by Bas Helman G4TIC. 

These files are downloadable from the HRD download center - http://hrd.ham-

radio.ch/downloads.html. 

Check out the cable solutions from: 

¶ G4ZLP http://g4zlp.ham-radio.ch/ and 

¶ West Mountain Radio http://www.westmountainradio.com/.  

Public Interfaces 

Other (non-HRD) programs are supported via a DDE interface (see DDE 

Support on page 61) and a serial port (see 3
rd
-Party Programs on page 149). 

Logbooks typically use these interfaces; for example contest-oriented logbooks.

http://hrd.ham-radio.ch/downloads.html
http://hrd.ham-radio.ch/downloads.html
http://g4zlp.ham-radio.ch/
http://www.westmountainradio.com/
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Installation 

Introduction 

The Ham Radio Deluxe kit is a standard Windows kit ï it supports Windows 98, 

Windows 2000, XP and more recent releases. Please note: version 3.4 is the last 

release that will óintentionallyô run on Windows 98. 

The Logbook uses the Microsoft Jet 4.0 Database Engine, see Database on page 

73 for more information. 

Ham Radio Deluxe 

Ham Radio Deluxe can be installed in under a minute. Special knowledge is not 

needed ï the kit does everything for you! 

You will not need to reboot your computer, HRD does not update your system 

files or change your systemôs configuration in any way. 

 

When you start the installation the first screen shows the release and build you 

are installing. 

 



 

You must accept the licencing conditions. Ham Radio Deluxe is free for radio 

amateurs and shortwave listeners, commercial use requires a licence. 

If you are a commercial (non-amateur user) stop the installation now unless you 

have a licence. 

 

 

Select the folder where Ham Radio Deluxe will be installed, the suggested 

default is usually sufficient. 
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Select the folder in the Start menu where the Ham Radio Deluxe entries will be 

added, the suggested default is usually sufficient. 

 

 

Click Install to start the installation. 

 



 

The progress of the installation is shown while the software is being installed. 

 

 

When the software has been installed select the programs to be started, then 

press Finish. 
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First Steps 

Connection 

Now that you have installed HRD you can try it out using a Dem-o-matic radio. 

This is a reasonably accurate simulation of the real thing, designed for use 

during presentations and while developing HRD when a radio is not available 

(on the train, in a plane, in an airport, stuck in a hotel room in Finland etc.). 

From the Start menu select Programs > Ham Radio Deluxe. Once the splash 

screen has closed you see the Connect window. 

 

 

Dem-o-matic 

The Dem-o-matic radios do not need cables ï simply select Dem-o-matic in the 

Company dropdown, select an option in the Radio dropdown, and then press 

Connect. 

They are ideal for demonstrating HRD when you do not have a suitable radio 

available. 

Options 

Company 

Select your radio manufacturer from the drop-down list.  



FlexRadio: you must install the vCOM virtual serial port drivers from Philip 

Covington (N8VB). These are used to provide the connection between HRD and 

the PowerSDR sofware that must be running before you try to create the 

connection with HRD. More information is available from http://www.flex-

radio.com/, to install the vCOM drivers see Annex: N8VB vCOM on page 163. 

ICOM: disable the CI-V Transceive option for best performance. 

Kenwood: make sure Packet communication mode is switched OFF (if 

supported). Most Kenwood radios require CTS and RTS to be ON for flow 

control. 

Radio 

Select your radio model from the drop-down list. 

COM Port  

The COM port on this computer where you have connected the radio interface 

cable. 

Make sure that you do not have other programs using the same port, for example 

mobile phones and personal organisers. 

Select 'Auto-detect' to try all available ports. 

Speed 

The speed used for communicating with the radio, check the speed setting via 

the radio's configuration menu. 

Select 'Auto-detect' to try all available speeds. 

CI-V Address 

ICOM only: the address assigned to the radio, consult the radio's handbook for 

the default address. This can also be configured via the radio's configuration 

menu. 

CTS 

Enables the CTS flow control, required for Kenwood radios. 

DTR 

Enables the DTR line when the COM Port is opened and leaves it on, usually to 

provide power for an interface cable. For Yaesu CT-62 and ICOM CT-17 

interfaces this can be left unchecked (off). 

RTS 

Enables the RTS line when the COM Port is opened and leaves it on, usually to 

provide power for an interface cable. For Yaesu CT-62 and ICOM CT-17 

interfaces this can be left unchecked (off). 

Connecting 

Press Start to connect to the radio. If you see the error below then the COM port 

is currently held open by another program. 

 

Check that you have not started another radio control program. Other culprits are 

PDA and mobile phone connections. Even if you have disconnected a device 

from a COM port you must make sure that the software is no longer running. 

http://www.flex-radio.com/
http://www.flex-radio.com/
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One connected HRD reads the radioôs frequency to ensure that the options you 

selected are correct. If you see the error below then HRD failed to read the 

radioôs frequency: 

 

If HRD can read the frequency the Connect window is replaced with the main 

radio display ï you are now using HRD! 

If HRD cannot read the frequency then check: 

¶ Correct COM port is selected, 

¶ Speed on radio is the same as the speed selected in HRD, 

¶ Your cable ï you may have a NULL modem cable when a normal 

serial cable is needed, 

¶ Cable is connected correctly to your PC (you may have more than 

one COM port), 

¶ DTR / RTS are selected if required to power an active cable such as 

CT-62 or a cable from third-party provider. 

If you still canôt get started refer to: 

¶ Annex: Command Tester on page 153, and 

¶ Annex: Portmon on page 161. 

Whatôs Next 

A taste of whatôs to come later in this guideé 

Appearance 

Set the appearance: 

¶ From the View menu select Colour Schemes, 

¶ Select Customise Layout and Program Options from the Tools 

menu. 
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Radio Display 

Introduction 

The HRD radio display has many, many features. This section attempts to 

describe everything you can do in this display. 

HRD is designed to be intuitive; nevertheless even the author has problems 

remembering all the available options! 

To aid in the clarity of the screenshots the LCD Scheme is used. 

 

 



Frequency Display 

 

Configuration 

See Frequency on page 34. 

Dropdowns 

If you have enabled dropdowns as part of the configuration just click on a 

dropdown and make a new selection. 

Mouse Wheel 

When you rotate the mouse wheel in the frequency display the currently active 

digit is incremented / decremented depending on the scroll direction. 

If you rotate while the cursor is over an inactive digit then the digit is activated. 

Up/Down 

The up-arrow, down-arrow, - and + keys increment / decrement the active digit. 

Mouse-click 

Select a digital by clicking over the digit. To increment / decrement click above / 

below the center of the digit and keep the mouse button pressed. 

Direct Entry  

To enter values just press a numeric key (0-9). The active digital is updated and 

the next digit to the right is made active. 

Press Enter to display the Enter Frequency window. 

 

Enter the new frequency, and then press Apply. 

If you check Auto-apply then the new frequency is applied every time you make 

a change. 

If you check Track this window is updated with changes made to the frequency 

display ï for example when you tune the radio manually. 

Griffin etc.  

Support for third-party devices such as the Griffin Powermate is available ï see 

Accelerators on page 39. 
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Tuning Dial 

Fine Tuning 

 

There are two fine tuning ranges ï Fine I and Fine II. In the Tuning menu select 

Show Fine II to show the second range. (If you are only showing Fine I then the 

title is Fine.) 

Set the range from the Tuning menu or by clicking the  button. 

To change the mouse wheel step click the  button (also set with the Mouse 

Wheel pane of Program Options on page 44). 

To change the frequency either: 

¶ Drag the marker with the mouse (and keep on dragging ï the bar 

will scroll to the left or right), 

¶ Rotate the mouse wheel (press Shift to increase the mouse wheel 

step by a factor of 2, press Ctrl to increase by a factor of 5),  

¶ Click in the tuning bar or on frequency text such as 14.235.0. 

Main Tuning 

 

The differences between a main tuning bar and a fine tuning bar are: 

¶ The range is fixed (defined by the Band Layouts on page 57), 

¶ The bar does not automatically scroll to the left or right. 

Band Selection 

The Band Section buttons are shown between the Fine and Main layouts. 

 

The buttons are: 

¶ ALT, 

¶ BSP, 

¶ Band buttons ï 160m, 80, é and 10m. 

ALT ï only displayed if you have two VFOôs displayed (for example Kenwood 

TS-2000), switches between the main and alternate (second) VFO. When 

highlighted you are tuning the second VFO with the tuning dial. 

BSP (bandspread) ï when you press BSP a new layout is dynamically created. 

The current band is split into multiple segments, for example the 20m band (14 

MHz ï 14.350 MHz) can be split into 7 segments, each of 50 kHz. 

To restore the previous layout press BSP and select Off. 

The band buttons select the corresponding band; the last used frequency and 

mode for the band are restored. 



Display Scroll 

 

If there is not enough room to display all the frequency ranges defined in the 

current band layout use this button to scroll the frequency ranges (bands) up or 

down. 

Band Selection 

 

The current band layout. Click here to select a different layout from the Bands 

menu. 

 

Date & Time 

 

Click here to set the clock format. 

 

Buttons 

 

What would a radio be without buttons? Press a button to active the option. If it 

is a button where the option state can be read from the radio ï for example the 

selected VFO ï the button indicates whether the option is currently selected. 

This should be obvious  . 
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Dropdowns 

 

When to press a dropdown button a popup menu is displayed. Select an option or 

press escape. If possible the dropdown displays the current selected option. 

Again, this should be obvious. 

Sliders 

 

Select the sliders that are displayed with the Sliders: Layout pane of Customise 

Layout ï see page 36. 

Use the mouse to adjust a slider value. 

In the View menu select whether sliders are displayed with the Slider Controls 

option.
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Customise Layout 

Introduction 

Used to define the appearance of the radio display, Customise Layout is selected 

from the Tools menu, or by pressing the Customise button. 

 

Schemes 

 

Schemes are pre-defined customizations created by author and by other HRD 

users. 

There are four default schemes shipped with HRD: Scheme #1 - #3 and the 

System Default. 

The HRD team and the HRD users have created the other schemes. Special 

thanks to Danielle in Northallerton, UK. 



Select a default scheme by pressing the scheme button (or select an entry and 

press Select); select one of the other schemes by double-clicking on the entry in 

the Schemes list. 

To save the current layout press Save ï you will be prompted for a Scheme 

name. 

Use Rename and Delete to organise the available schemes. 

Layout 

 

HRD is a data-driven program. For each radio there is a table of supported 

commands and associated button / dropdown / slider names. The layout order is 

more-or-less alphabetical. 

An early complaint was that the buttons positions were not user-definable; as a 

result the Layout window was designed. 

Donôt be put off by the amount of information in this window ï take it slowly 

and read the information here. 

The layout definition is saved on a per-radio basis in the registry. 

Dropdown Button / CAT Command / Macros 

You can create new buttons  - for example, to create a USB button from the 

Mode dropdown: 

¶ Select an empty button position ï the selected entry will start to 

blink (you can reposition this button later), 

¶ Press Select (above the Save and Load buttons), 

¶ In the Configure Button Mapping window select Mode : USB and 

enter the text to appear on the new button, then press OK. 



 Customise Layout  ¶  31 

 

 

¶ The previously empty button position now has a new value ï USB! 

Hiding  

Hide dropdowns hides the dropdown buttons to the right of the layout window, 

releasing two columns where you can assign new button definitions. 

Hide status texts hides the three top-left meters (-1-, -2-, -3-) and the status text 

area underneath, releasing two columns where you can assign new button 

definitions. 

Moving Entries 

Move the selected entry by simply dragging it with the mouse or by using the 

four arrow-buttons. 

    

Removing Entries 

To remove an entry either drag it into the Unassigned list or right-click on the 

button and select Clear from the popup menu. 

Dropdowns 

Select the dropdown menu, and then simply drag an entry to an unused location 

in the display. 

If you drag to a location that already has a definition the current definition is 

removed, if a standard button it is returned to the unassigned list.  

Unassigned 

Entries in the Unassigned list are standard buttons that are not currently 

displayed. Simply drag an entry to an unused location in the display. 

If you drag to a location that already has a definition the current definition is 

removed, if a standard button it is returned to the Unassigned list. 

Styles 

In the Buttons pane (page 32) you define up to seven button styles, shown here 

in the Button Styles group. 

To assign a style to a button either: 

¶ Drag the style over the button, or 

¶ Click a style to apply it to the currently selected (blinking) button. 

Save / Load 



To distribute your layouts with other users of your radio model use the Save and 

Load buttons. 

Buttons 

 

Define: 

¶ Seven button colour combinations, 

¶ The font, and 

¶ The button size. 

The default button size is small; this is so that users with low resolutions such as 

800 x 600 still have a usable configuration. 

There are no rules when using the button size; select the size which pleases you 

most. 

For the technical readers the button size is tied to the font size of the radio 

display form (font is Microsoft Sans Serif, size is 8, 9, 10 or 12 point). 

Changing the font size simply changes the font assigned to the form. 
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Faceplate 

 

Background 

These colours are applied to the background area of the display and to the 

transmit meters (if any) such as PWR, SWR and ALC. 

Status Window 

The status window displays information which you cannot normally change 

using buttons or sliders in HRD. 

Typical examples are Scanning status, Split mode and Memory channels. 

Clock Position 

The clock is displayed to the left, right or both sides of the band title. 



Frequency 

 

If your radio supports simultaneous access to two VFOôs (Kenwood, some 

Yaesu) then HRD will display two VFOôs, otherwise just one VFO is displayed. 

First select the VFO you are updating ï main or sub. 

The colours you can set are: 

¶ Background, 

¶ Frequency ï the digits, 

¶ Active Posn ï the bar above and below the current digit, 

¶ Inactive Posn ï the bar above and below the other digit, 

The Font can also be set, use the Main > Sub and Sub > Main buttons to copy 

settings between VFOôs. 

Dropdowns 

The dropdown buttons (Mode, Filteré) can be displayed at the top of the main 

frequency display. 

Select: 

¶ None (no dropdowns), 

¶  Mode (only the mode dropdown) or 

¶ All (all dropdowns). 

If Mode or All is selected you can check Add Border to add a border around the 

text. 

If All is selected you can check Include Title to add the Dropdown buttonós title 

(if there is room). 
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Meters 

 

The design aim of the bar meters was heavily influenced by my fine Sony stereo, 

still giving fine service here in the HRD R&R suite after some 15 years of abuse. 

The Background and Text colours should be obvious. 

There are three graduation colours: 

¶ Bars: Low ï the first bar colour, 

¶ Bars: High ï the colour at the position set by the High Position 

slider, and 

¶ Bars: Free ï the colour for the free (empty) bars. 

If you check Show peak reading the recent peak value is displayed. 

When HRD is in TX mode the S Meter value is replaced by the value selected in 

the Main and Sub dropdowns, the value you select must be displayed by HRD in 

the upper right hand corner of the display. For Kenwood radios the value to be 

displayed is selected with the meter slider or the individual buttons (SWR / 

Comp / ALC / dB). 

If you check the Always updateé option then the S Meter is updated when you 

change frequency ï this results in slower performance. 



Sliders: Appearance 

 

If supported by your radio, sliders are displayed at the bottom of the display. 

Here you define the appearance of the sliders. 

These colours are optionally applied to the sliders in the Advanced selection 

windows (select Advanced from the View menu). 

Sliders: Layout 

 

Here you select the sliders to be displayed. Define up to 6 layouts, for example 

one layout for SSB and another for CW 
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Tuning Dial 

 

Here you define the colours, fonts and band button positions. 
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Program Options 

Introduction 

Used to define various HRD features, Program Options is selected from the 

Tools menu, or by pressing the Options button. 

 

 

Accelerators 

 

Define accelerators for use with the Keyboard or with programmable interfaces 

such as the Griffin Powermate. 

When you press Add the definition window is displayed. 



 

Here Ctrl+Alt+W is assigned to the Tune button. Keyboard combinations are 

assigned to display buttons and arrow keys. 

The HRD menu has pre-assigned accelerators; these cannot be redefined. 

Comms 

 

Normally you will not have to change the default settings. 

¶ Read timeout ï serial port timeout. 

¶ Switch off ï some radios such as the FT-817 can be powered down 

using a CAT command. If this option is selected you are prompted 

to switch off the radio. 

¶ Polling ï to reduce CPU load for slower systems. 

¶ Dual VFO tracking ï if selected both VFOôs are tracked on every 

refresh. Only of use with Satellite Tracking (page 129). 

¶ Refresh interval ï the interval between consecutive refreshes of the 

display. 
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COM Port TX 

 

Some early ICOM radios do not support switching between TX and RX using 

CAT commands. The only way to enable computer controlled TX/RX this is by 

toggling a COM port pin. 

You require a special CAT cable if you select this option. 

ICOM Calibration 

 

ICOM radios return a S Meter value between 0 and 255, normally 0 is S0, 12 is 

S1 and so on. 

As a S Meter unit is 6 dB the algorithm applied is to divide the returned value by 

two to get dB, then divide dB by 6 to get S units. 

Some radios such as the IC-706 have a different logic ï use the Offset and Scale 

values to adjust the returned values so that the S Meter in HRD corresponds to 

the S Meter on your radio. 



Info: Modes 

 

Mainly for use by the HRD programming team, all modes for each radio are 

listed. For each mode the mapping to the internal HRD mode is shown. 

Info: CAT Support 

 

Mainly for use by the HRD programming team, all commands are listed for each 

radio. 

Press Radio for a list of all supported radios. 

To display the commands: 

1. Select a radio, 

2. Press Viewer. 
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Internet 

 

HRD is able to detect whether you have an Internet connection with 

InternetGetConnectedState(). Uncheck this option if you do not want Internet 

access. 



Out Of Band 

 

Configure the optional sound files played when you tune in / out of band. 

Mouse Wheel 

 

Define the tuning step when rotating the mouse wheel over the active tuning bar. 
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Selection Window 

 

The appearance and operation of the selection window. 

Single-click ï normally the Favourites tree folders are opened / closed with a 

double-click. Check this option to enable single-click operation. 

Show numeric value ï the Select Windowsôs Advanced slider values are 

optionally superimposed on the slider. 

Show the Options icon ï historical support for the version 2 Advanced slider 

look and feel. 

Themes 

 

HRD uses the excellent programming library from Codejock Software to support 

toolbars, main window tabbing and docking pane options 

Docking panes are used for optional windows such as: Bandscope, Calendar, DX 

Cluster, Logbook, Selection, Shortwave Database and WinKey. 

Main Theme 

Select whichever visual theme you want ï Office 2003 is an acceptable default. 

System Theme 

http://www.codejock.com/


When you select Office 2003 or Windows XP for Menus and Toolbars you can 

select an optional System theme. 

Main Tabs 

If you have more than one main window open ï for example Radio and Logbook 

ï then the main tabs are a useful way of switching between windows. 

 

 

Updates 

 

Select how frequently HRD reminds you to check for new updates. 

Yaesu 
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Special options for Yaesu radios. Due to firmware ófeaturesô in the FTDX-9000 

it is necessary to wait up to 250ms after writing a command to the radio. With 

any luck Yaesu will fix this at some date in the future. 
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Audio 

Introduction 

HRD has a built-in audio grabber and audio playback. The long-term aim is to 

automatically add audio clips into the logfile. 

Audio Grabber 
The audio grabber stores incoming audio in MP3 files using the MP3 tags to 

store information about the radio settings (or any other information you feel to 

be important). 

An alternative to MP3 would be Windows Media format (WMA) but the 

programming of WMA files is rather complex. 

To display the audio grabber select Audio Grabber from the Tools menu. 

Record 

 

Here you have the standard recording buttons. From left to right: 

¶ Record, 

¶ Stop, 

¶ Reset current recoding, 

¶ Restart (close current file first), 

¶ Browse for MP3 files. 

You also set a file limit ï a downside of MP3 is that the tags are written at the 

end of the file when it is closed, so to avoid losing information in the event of an 

unexpected event it is best to use more, smaller files. 



Folder 

 

Here you select the folder where the MP3 files are stored. 

Quality 

 

Here you select the bandwidth and quality. Modern computers have more than 

enough CPU power to support a very high quality. A bandwidth of 4.5 kHz is 

usually acceptable unless you are recording a WFM broadcast. 

Soundcard 

 

Select the soundcard that you are recoding from. 

Tags 

 

Here you see the values stored in the MP3 tags. To change the values just add 

the new text and then press Apply. 

Audio Browser 

Use the audio browser to playback MP3 files. 
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 Select the folder to browse 

 Select default folder 

 Refresh the current folder 

Select MP3 player ï a basic MP3 player is built into HRD, however you can 

select an alternate player such as the excellent Windows Media Player. Press 

Default to select the default player. 

Peter PH1PH came across IrfanView ï an excellent utility. 

MP3 Player Options 

Select a file to play from the list at the bottom of the window. 

 Play currently selected file 

 Pause 

 Start again 

 Stop 

From 

 Start at beginning of file 

 Set óFromô to the current position 

To 

 To end of file 

 Set óToô to the current position 

http://www.irfanview.com/


Use the From and To slider positions to select the part of the file to repeated over 

and over and over again. This is useful for determining exactly what the station 

was sending. 

Other Options 

The other options are: 

¶ Copy ï copy the selected files to another folder. 

¶ Delete ï delete the selected files. 

¶ Move ï move the selected files to another folder. 

¶ Rename ï rename the selected file. 

¶ Artist / Album / Title / Description ï change the MP3 tags. 
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Auxiliary Switching 

Introduction 

A standard PC comes equipped with an 8-bit parallel port that can be used to 

switch auxiliary equipment such as antennas, bandpass filters and power 

amplifiers. 

Ham Radio Deluxe supports the parallel port via fully configurable manager and 

monitor displays. 

Typical uses of this option are to switch antennas, either automatically as the 

frequency changes, or by selecting an option from the Parallel Port pane of the 

selection window. 

Technology 

The parallel port sends 8 bits at a time. The layout of the parallel port pins is 

shown below.  

 

The data pins are shown in red; D0 is pin 2, D7 is pin 9. 

To indicate that a bit has a value of 1, a charge of 5 volts is sent through the 

correct pin. No charge on a pin indicates a value of 0. This is a simple but highly 

effective way to transmit digital information over an analog cable in real-time.   

Manager 

The manager window is invoked from the Tools > Parallel Port menu. 

Definitions 

Each definition consists of: 

¶ [X] Enabled selection ï if not checked then the definition is 

ignored when Ham Radio Deluxe detects a new frequency. The 

definition is still shown in the selection window if this option is 

enabled. 

¶ Title ï a description of the antenna or component that will be 

switched when the entry is selected. 



¶ From ï the lower end of the frequency range. 

¶ To ï the upper end of the frequency range. 

¶ Port ï the LPT port to be switched by the definition. 

¶ D0-D7 ï the parallel port data bit settings, each bit is either 1 (on) 

or 0 (off). D0 is pin 2, D7 is pin 9. 

Port Address 

The default port addresses for LPT1, LPT2 and LPT3 are 0378, 0278 and 03BC 

respectively. If your computer has a different configuration just select the 

address that corresponds to the port. 

You will find the port address via the Device Manager settings display located in 

the System control panel applet. 

 

In the Windows XP example below the base address is 0378. 

Various 

The options are: 

¶ Auto-switch: as the frequency displayed by Ham Radio Deluxe 

changes a lookup is made against the parallel port definitions and 

the parallel port switched to the configuration for the first 

definition in the list that matches the new frequency. 
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¶ Selection window: displays a Parallel Port pane in the main HRD 

selection window. See Selection Window on page 45. 

Monitor 
The monitor window is started from the Tools > Parallel Port menu. The 

monitor: 

¶ shows the current state of the data pins for a selected parallel port, 

¶ allows you to select a definition, and 

¶ toggle the data pins directly. 

 The Definition field shows the definition that matches the current pin selection 

(if any). 

 Selection Window 

To display the selection window select the selection window option in the 

Parallel Port Manager. 

 

The options are: 

¶ Manager ï starts the Parallel Port Manager. 

¶ Monitor ï starts the Parallel Port Monitor. 

¶ Auto-switch ï if enabled (tick) then a match is made with the first 

enabled definition when the frequency changes. If not enabled 

(cross) then a match is not made. 

¶ Definitions ï click on a definition to apply the definition to the 

port. 

The icon indicates whether a definition that has been enabled or disabled. 

Disabled definitions can be selected in this window; they are only ignored when 

matching a new frequency against the list of definitions.
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Band Layouts 

Introduction 

A necessary feature of a fully customizable radio program such as HRD is the 

definition of custom band layouts. 

The IARU regions have own band plans; there is no doubt that these will change 

in the future. 

Consider also the traditionalist who has never owned a microphone in his life 

and is only interested in the CW portions of the bands ï he wants his own band 

layouts. 

Manager 

To start the Manager select Manager from the Bands menu. 

 

Here you see the existing definitions. In the Edit menu you have the expected 

New, Copy, Modify and Delete options. 



Adding A Definition 

In this example a band layout is created for our CW enthusiast. Select New from 

the Edit menu to create a new definition using the Band Layout Editor. 

 

In the Title field enter CW Only. 

From the Edit menu select New to define a new frequency range. 

¶ In the Band field enter 160m 

¶ In the From field enter 1.800.000 

¶ In the To field enter 1.830.000 

¶ Ensure Enable is checked 

¶ Press OK 

 

When you press OK the frequency range is added to the band layout. 

Repeat for 80m and 40m: 

¶ 80m, 3.5MHz to 3.55MHz, 

¶ 40m, 7.0MHz to 7.05MHz. 

The band layout now looks like this: 



 Band Layouts  ¶  59 

 

To rearrange the order of the frequency ranges just select a range and use the 

Move menu options or the Move buttons  . 

When you have finished your new layout press OK. The CW Only definition is 

added to the band layouts. In the Band Layouts window press OK to save the 

definitions and close the window. 

Copying A Definition 

To copy an existing band layout: 

¶ Start the Manager, 

¶ Select the entry to be copied, 

¶ Select Copy from the Edit menu, 

¶ Enter the new title, 

¶ Change the frequency ranges are appropriate, 

¶ Press OK. 

Selecting 

To select a band layout either: 

1. Open the Bands pane in the Selection window (select Display from the 

Bands menu) and select an entry in the list, or 

2. Click on the Band Title 160m ï 10m (Region 1) in the radio display 

and select a new layout from the popup window. 
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DDE Support 

Introduction 

HRD uses dynamic data exchange (DDE) for inter-process communication. 

DDE allows two or more applications running simultaneously to exchange data 

and commands. 

See also 3
rd
-Party Programs on page 149. 

Available Support 

Select DDE Monitor from the Tools menu to display the supported DDE items. 

 

Commands 

The commands below are supported by HRD. 



 

Add ADIF Record 

ADIF <data>  

Adds a record to the logbook; the record is supplied in ADIF format. Used by 

PSK31 Deluxe. 

Refresh 

REFR button_status  

Refreshes all buttons. 

REFR dropdown_list  

Refreshes all dropdown. 

Set Button 

BUTN button_title=value  

Sets a button state. For normal buttons the value is either on or off. 

 If title starts with @ then itôs a dropdown, the value must be a dropdown value. 

Set Dropdown 

DROP button _title=value  

Selects a dropdown value. 

Set Frequency 

FREQ <hertz> 

Sets the frequency to the value supplied in Hertz. 

Set Mode 

MODE <mode> 

Sets the mode to the supplied value. 

Top Window 

TOPW 

Makes the HRD the top-most window in the Z-order, in other words brings HRD 

to the front of your monitor.
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DX Cluster 

Introduction 

A DX Cluster is a means for Amateur (Ham) Radio operators to tell each other, 

in real-time, about DX stations (other interesting or rare Amateur Radio stations 

all over the world). 

(From http://www.dxcluster.org/ by Dirk Koopman G1TLH) 

One station is set up with Packet Cluster and is linked to one or more other 

stations who have installed the software. These nodes when connected are called 

a cluster. Clusters are connected to clusters, expanding the network. Individual 

users connect to the nodes on a frequency different from what the node stations 

are linked on. Users are capable of announcing DX spots and related 

announcements, send personal talk messages, send and receive mail messages, 

search and retrieve archived data, and access data from information databases 

among its many features. 

(From http://www.dxcluster.org/ by Chuck K6PBT) 

HRD supports: 

¶ OH2AQ web-based cluster (the original and most widely used), 

¶ HRDôs own web-based cluster, 

¶ Direct connections to a DX Spider node using a DX cluster client 

(which in turn uses the telnet protocol). 

The OH2AQ and HRD clusters are available using just your web browser. 

http://www.dxcluster.org/
http://www.dxcluster.org/
http://oh2aq.kolumbus.com/dxs/
http://dxcluster.ham-radio.ch/


OH2AQ 

 

HRD 

 

Starting 

Select DX Cluster from the Tools menu. 


